Uusi ytimen virhe, POC, herättää toiveita iOS 13: sta.3.1 karkaaminen

Uusi ytimen virhe, POC, herättää toiveita iOS 13: sta.3.1 karkaaminen 1

Jailbreak-työkalut, kuten unc0ver, luottavat usein julkaistuihin hyödykkeisiin laajentaakseen laiteohjelmistotukia Apple esittelee uusia iOS-versioita. Viime kuukausien aikana unc0ver on saanut tukea iOS 13: lle.0-13.3jättäen iOS 13: n.3.1 pölyn käyttäjät. Nyt kun iOS 13.4 on julkisesti saatavilla, kultainen jailbreaker -sääntö tulee uudelleen esiin, eli "pysyä pienimmällä mahdollisella ohjelmistolla".

Kirjoittamishetkellä tämä on matalin mahdollinen laiteohjelmisto Apple jatkaa sen allekirjoittamista iOS 13: lle.3.1, mutta unc0ver ei vielä tue tätä iOS-version. Onneksi lupaava uutta näyttöä ydinvirheistä iOS 13 -tukikäsitteessä.3.1 on jakanut Twitter käyttäjä @ _simo36, ja kunnes on varmistettu, pääseekö tämä virhe tfp0: een (lue / kirjoita ytimen muistiin), se voidaan saada hiekkalaatikosta.

Uusi ytimen virhe, POC, herättää toiveita iOS 13: sta.3.1 karkaaminen 2

Jos tfp0 voitaisiin saavuttaa tällä uudella POC-ytimen virheellä, se olisi hieno uutinen jailbreak-yhteisölle, koska se tarkoittaisi, että unc0verin kaltaiset jailbreaksit voisivat mahdollisesti saada iOS 13 -tuen.3.1. IOS 13 on äskettäin julkaistu.4, mutta se voi olla ainakin askel eteenpäin niille, jotka ovat vahingossa päivittäneet tai eivät vaihtaneet iOS 13: een.3 vähän ennen unc0verin uusimpien versioiden julkaisua.

Tunnetusti tuntematon sisäinen beetatestaaja Benjamin Weaver kirjoitti eilen Twitterissä, että innokkaita jailbreakereita ei tule asentaa iOS 13: een.4ja niiden, jotka tekivät, tulisi vaihtaa iOS 13: een.3.1 heti ennen Apple sulkee allekirjoitusikkunan:

Uusi ytimen virhe, POC, herättää toiveita iOS 13: sta.3.1 karkaaminen 3

Hakkeri ja pääohjelmoija unc0ver Pwn20wnd tweettivät edelleen, lisääen uskottavuutta teoreettiseen joukkueeseen, joka tutkii parhaillaan mahdollisuutta hyödyntää tätä virhettä. Tämä ei kuitenkaan takaa sen kannattavuutta, ja alentamissuositus on parhaimmillaan vain varovainen.

Riippumatta tapauksesta ja aiheuttaako tämä virhe jailbreak kaikille laitteille, joissa on iOS 13.3.1 tai ei, on edelleen suositeltavaa laskea iOS 13: aa niille, jotka tuntevat jailbreakia.4 ja vältä ohjelmistopäivityksiä. Jos jailbreak vapautetaan, se tukee todennäköisemmin ohjelmiston vanhempia versioita; sanoi, iOS 13.3.1 on paljon suurempi mahdollisuus rikkoa vankilaa kuin iOS 13.4.

Kiinnostuneet voivat lukea lisää POC-ytimen virheestä ohjelmoijan GitHub-sivulla.

Erityisesti jarabreak checkra1n -laitetta voidaan jo käyttää pwn iOS 13: een.3.1 ja jopa iOS 13.4 koska se käyttää bootrom -laitteiston hyväksikäyttöä, mutta tämä hyödyntää vain A7-A11-laitteita, iPhone 5: stä iPhone X: ään, kun taas unc0ver pystyisi käsittelemään melkein mitä tahansa laitteita Рmyös uudempia.

Oletko innostunut siitä, toteutuuko jotain POC @ _simo36: lla? Keskustele alla olevassa kommenttiosassa.